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What does Calendar Master do?

Calendar Master is designed to replace the use of purchased calendars. These calendars
are the ones you buy and hang on your refrigerator or office wall, and then start writing on
with appointments, birthdays, and anniversaries. (If you don't use hardcopy calendars,
you probably don't need this program). Some of the problems with this method is that
each year, you have to re-enter birthdays and anniversaries, repeating appointments have
to be repeatedly entered, and, the calendars frequently get cluttered with scribbles and
you run out of room.

Calendar Master lets you enter appointments (called events in Calendar Master), both one
time and recurring, as well as yearly repeating events such as birthdays and anniversaries,
and then print out a calendar with those items printed in the various days. The idea is that
you would enter all the birthdays, anniversaries, or appointments you want to remember.
You would then print out calendars for the current month as well as the next couple of
months. You then use the calendars as you normally would by writing in new
appointments on the appropriate days. Periodically, you would fire up Calendar Master,
enter the changes to the calendars that you have made by hand, and then print out the
next appropriate set of calendars and start over.

As you can tell, this scheme is best suited for a situation where you don't have your
computer on all the time or you want to make calendars for someone who doesn't have a
computer (and access to a PIM).

Calendar Master is not a PIM. It will not remember addresses, phone numbers, or remind
you to pay your bills. It will print a calendar from any month along with any other
information you enter into it.



New Features in Version 1.1

Several things have been added in Version 1.1 to make Calendar Master easier and more
fun to use. The first and most noticable change is the 3-D look. This doesn't change the
functionality much but hopefully you'll agree that it makes the program more pleasing to
use.

Status panels have been added to the lower left corner of the Calendar Display. These
panels give the current date and time, show printing, saving, and loading status, and give
hints, as you move over them with your mouse, on what various buttons and controls will
do if you click them.

Calendar Master now gives you control over the fonts used for various event types and
other portions of the calendar. See Font Control.

Now you can specify a title for each month that is printed in the top center of the calendar.
See Month Titles.

Also new for version 1.1 is a change to the file format for Calendar Master data files.
Version 1.0 calendar files will not be read properly by Version 1.1. Registered users of
Calendar Master will get a utility that will convert a file from version 1.0 to version 1.1.
This is meant as a gentle nudge for those users who have a lot of data in their Calendar
Master files to go ahead and register the program.



Getting Started

To run the program, use the Windows File Manager to open the directory where Calendar
Master was installed. Double click on the program name (CALMAST.EXE).

There are lots of other ways to run Windows programs. Please see your Windows
documentation for information on how to create Program Groups and ltems.

After the introductory screen you will be presented with the Calendar Display. This is the
main window of Calendar Master. From here you can navigate to various months, open the
Event Editor, open and save Calendar Master information files, print calendars, and exit the
program.



Viewing a Particular Month

To view a specific month in the Calendar Display, you use the navigation buttons on the left
side of the window. The month being displayed is shown above the scroll buttons. The
inner scroll buttons change the month (the left button changes to the previous month and
the right button changes to the next month). The outer scroll buttons change the year.
You can drag the slider left or right to display previous or future months. If you click in the
area between the slider and the buttons, you will jump ahead or back by 3 months. The
additional buttons below the scroll buttons allow you to quickly display the current month
(based on the system clock) or hop directly to a specific month in the currently displayed
year.

You will note that, depending on the way the dates fall, some months will have their last
few days wrap up to the top line of the calendar. In other words, Calendar Master only
displays 5 rows (weeks) for any month so for those months that have days that span 6
rows, the sixth row is combined with the first row. This was done to provide as much room
as possible in the day cells for printed and written events.

If you have event information entered into Calendar Master, the number of events (both
Normal/General and Anniversary events) for each day will be displayed on the calendar.



Entering Events

Events are added or modified by navigating to the desired month in the Calendar Display
and then clicking on the day that corresponds to the event you want to add or modify. This
will bring up the Event Editor where you can enter the time and text of the event or select

an existing event and modify its parameters.

You can enter Normal events, General events, Anniversary events, or Recurring events.



Entering/Modifying Normal Events

To enter a Normal event, click in the Time box in the Event Editor. Type in the time of the
event in either 24 Hr or am/pm format. The following are valid times;

This: Means This:

01:30 1:30 in the morning
3:30p 3:30 in the afternoon
22:45 10:45 in the evening
8:30 am 8:30 in the morning

Note that you cannot set a duration for an event. Only the start time is allowed. After
entering the time, press the TAB key or click in the Event box and type in the text of the
event. You can make the event a Recurring or Anniversary event by clicking the
corresponding option button. Note that the time will be ignored in an Anniversary event.
If you need the time field, make a Normal Recurring event.

When finished entering the event text, press Return, click the Add button, or press Alt + a.
The event will be added to the Event list at the top of the display.

To delete an existing event, select the event from the Event list. The event information
will be displayed in the Edit area. Note that the Add button will change to Update and
the Delete button will become enabled. Click the Delete button or press Alt + d.

To modify an existing event, select the event from the Event list. The event information
will be displayed in the Edit area. You can change the time, text, or type of the event in
the same manner as is done for adding events. When finished modifying the event, press
Return, click the Update button, or press Alt + u.

To change the day displayed in the Event Editor, click the scroll buttons or drag the slider
at the top of the display. These buttons change the display to either the next day (the
right button) or the previous day (the left button).

When you are finished entering/modifying events, click the Close button at the top right of
the display or press Alt + c.



Entering/Modifying General Events

To enter a General event, click in the Event box in the Event Editor and type in the text of
the event. Don't enter a time in the Time box. You can make the event a Recurring or
Anniversary event by clicking the corresponding option button.

When finished entering the event text, press Return, click the Add button, or press Alt + a.
The event will be added to the Event list at the top of the display.

To delete an existing event, select the event from the Event list. The event information
will be displayed in the Edit area. Note that the Add button will change to Update and
the Delete button will become enabled. Click the Delete button or press Alt + d.

To modify an existing event, select the event from the Event list. The event information
will be displayed in the Edit area. You can change the time, text, or type of the event in
the same manner as done for adding events. When finished modifying the event, press
Return, click the Update button, or press Alt + u.

To change the day displayed in the Event Editor, click the scroll buttons or drag the slider
at the top of the display. These buttons change the display to either the next day (the
right button) or the previous day (the left button).

When you are finished entering/modifying events, click the Close button at the top right of
the display or press Alt + c.



Entering/Modifying Anniversary Events

To enter an Anniversary event, click in the Event box in the Event Editor and type in the
text of the event. The Time box is ignored for an Anniversary Event. You can make the
event a Recurring or Normal event by clicking the corresponding option button.

When finished entering the event text, click the Anniversary option button or press Alt + v.
Then press Return, click the Add button, or press Alt + a. The event will be added to the

Event list at the top of the display. Anniversary events are displayed in the Event list with
an "A" preceding the text of the event.

To delete an existing event, select the event from the Event list. The event information
will be displayed in the Edit area. Note that the Add button will change to Update and
the Delete button will become enabled. Click the Delete button or press Alt + d.

To modify an existing event, select the event from the Event list. The event information
will be displayed in the Edit area. You can change the time, text, or type of the event in
the same manner as done for adding events. When finished modifying the event, press
Return, click the Update button, or press Alt + u.

To change the day displayed in the Event Editor, click the scroll buttons or drag the slider
at the top of the display. These buttons change the display to either the next day (the
right button) or the previous day (the left button).

When you are finished entering/modifying events, click the Close button at the top right of
the display or press Alt + c.



Entering/Modifying Recurring Events

To enter a Normal Recurring event, click in the Time box in the Event Editor. Type in the
time of the event in either 24 Hr or am/pm format. The following are valid times;

This: Means This:

01:30 1:30 in the morning
3:30p 3:30 in the afternoon
22:45 10:45 in the evening
8:30 am 8:30 in the morning

Note that you cannot set a duration for an event. Only the start time is allowed. If you
want to enter a General Recurring event, don't enter a time in the Time box. Note; you
can't enter a Recurring Anniversary event.

Press the TAB key or click in the Event box and type in the text of the event.

When finished entering the event text, click the Recurring... option button or press Alt + .
This will display the Recurring Event dialog. This dialog allows you to specify the
parameters of the recurring event. When finished specifying the information in the
Recurring Event dialog, press Return, click the Add button, or press Alt + a. The event will
be added to the Event list at the top of the display. Recurring events are displayed in the
Event list with an "R" preceding the text of the event.

To delete an existing event, select the event from the Event list. The event information will
be displayed in the Edit area. Note that the Add button will change to Update and the
Delete button will become enabled. Click the Delete button or press Alt + d. The Delete
Recurring Event dialog will be displayed. This will allow you to delete various subsets of
the recurring event.

To modify an existing event, select the event from the Event list. The event Information
will be displayed in the Edit area. You can change the time, text, or type of the event in
the same manner as done for adding events. If you change a recurring event to either a
Normal/General event or an Anniversary event, a message will be displayed explaining that
only the current event (of the recurring series) will be changed. If this is what you want
then select OK in the message dialog. If instead, you want to change the entire series of
recurring events to one Normal or Anniversary event, then select Cancel in the message
dialog and then select the Delete button in the Event Editor and delete 'All but this
event' and then re-select the event and change the type.

When finished modifying the event, press Return, click the Update button, or press Alt + .
To change the day displayed in the Event Editor, click the scroll buttons or drag the slider
at the top of the display. These buttons change the display to either the next day (the
right button) or the previous day (the left button).

When you are finished entering/modifying events, click the Close button at the top right of
the display.



Overriding the Default Font

The effects applied to the events printed on the calendar are controlled by the Font Control
dialog. These effects can be modified however by the check boxes in the Font Effects
portion of the Event Editor. The check boxes are used to add the corresponding effect to
the event being edited.

Note that you can't undo an effect specified by the default font. In other words, if the
default Anniversary event font (as specified in the Font Control dialog) included bold, you
cannot "un-bold" a specific Anniversary event. You can only add font effects to the default
effect.



Font Control

Calendar Master lets you control some aspects of the fonts used for the things printed on
the calendar. You can control the font name and effects for Normal/General events,
Anniversary events, Month and Year, Month Title, and the days-of-the-week labels. You can
also control the font size for events. The fonts that you can use are those that are already
on your computer. Calendar Master does not supply any of the fonts its uses. Calendar
Master defaults to using "Times New Roman" if no custom fonts are specified.

Font usage is controlled by choosing Fonts... from the Customize menu in the Calendar
Display. This brings up the Font Control dialog. At the top of the dialog is a button bar
which controls which calendar object's font is being edited at any one time. As you move
the mouse over the buttons, a description appears in the status panel at the bottom of the
dialog that explains what the button does. In the middle of the dialog are the controls that
let you specify the font name, size, and effects. When you click on a calendar object
button, the controls in the center update to reflect the current values. You can change the
values and then click on another object button to change that object's values. When
you're done, click OK and the changes will be saved. Cancel will cancel all changes made
since the dialog was displayed.

As you move the mouse into the font control area, the status panel at the bottom changes
to display a sample string with the current font values to give you a preview of what the
font looks like. The font size value is not reflected in the status panel since it can be hard
to see some fonts at typical sizes used for printed calendars.

The font size control is also disabled for the Month/Year, Title, and days-of-the-week
calendar objects. This is to preserve the overall layout of the printed calendar.

This dialog controls the default font effects used for events. These can be overridden on
an individual basis in the Event Editor.

This font information is saved with each Calendar Master file and so can be setup
differently if you use multiple Calendar Master files.



Month Titles

Calendar Master lets you specify a Title to be printed at the top center of the Calendar. To
enter the Title text, in the Calendar Display, choose Month Titles... from the Customize
menu. A dialog box will appear that will let you enter Title text for each month. Note that
if you want the same text for all months you can just enter the text in the box for January
and then click Replicate January. The text in the January box will be copied to all other
months. Click the Clear All button to erase all the title text boxes. When you have
finished entering the title text, click OK to save the information.

Note that the length of the Title that will fit between the month and the year on a printed
calendar is dependant on the Title font used and the text of the font itself (if a proportional
font is used). The Title will show up on the Calendar Display but really can't be used for a
guide since the Calendar Display and the printed calendar are not at the same scale. You
basically just have to try it and see what works.

A note on the Title shown on the Calendar Display. Most likely, the entire Title won't all fit
between the month and the year and will be clipped on the display. If you want to see the
whole title, you must click on the title and then use the arrow keys or Home and End keys

on the keyboard to scroll the Title right and left. You can delete or add to the Title too but
it won't have any affect on the Title and the next time you display the month, the Title will

be back to what it was when set in the Month Titles dialog.



Printing Calendars

To print a calendar, use the navigation buttons to display the desired month (see Viewing a
Particular Month). If you have saved information into a Calendar Master file and you
haven't loaded it yet, you may want to load the file at this time.
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Ensure that your printer is on and then either click the print button on the Toolbar or

choose Print from the File menu. Note, you can only print one month at a time. After
you have selected print, a percentage complete bar will appear to show printing progress.

Event text will wrap to two lines when the calendar is printed. Event text longer than two
lines is clipped at the edge of the day cell on the printed calendar. This limits the printable
length of event text to around 50 characters depending on whether it is a Normal or
General/Anniversary event.

Anniversary events are printed in bold one line below any other events.

The printer setup can be changed by selecting Print Setup... from the File menu. This
will bring up the Setup dialog box for the default Windows printer. Note that this changes
the printer setup for all applications that use the default Windows printer. This also means
that if other applications change the default printer setup, those changes will also affect
how Calendar Master prints calendars.



Saving Calendar Master Information

Once you have entered events into Calendar Master, you should save the information into a
Calendar Master file. These files can then be read back into Calendar Master for updating.
You can have multiple Calendar Master files which you can use for different purposes but
only one Calendar Master file can be loaded at any one time. Calendar Master files should
have an extension of .CMS.

=]
To save your event information into a file, click the save button H on the Toolbar or
select Save from the File menu. If you have not previously read in information from a
Calendar Master file, you will be prompted for the directory and filename in which to store
the event information. If you have previously opened a Calendar Master file, then the
current information will be saved back into that file. If you want to change the name of the
file the information is to be saved into, select Save As... from the File menu.

Calendar Master files are plain ASCII files which you can look at and edit in your favorite
text editor.

The format of Calendar Master files has changed from version 1.0 to version 1.1. The
program will not read version 1.0 files. Registered users can obtain a utility to convert
version 1.0 files to version 1.1 format.



Opening a Calendar Master File

If you have saved event information into a Calendar Master file, you can retrieve that
information and add to it or update it. You can have multiple Calendar Master files which
you can use for different purposes but only one Calendar Master file can be loaded at any
one time. Calendar Master files should have an extension of .CMS.

To open a Calendar Master file, click the open button @ on the Toolbar or choose Open
from the File menu. The File Open dialog box will appear where you can select the
Calendar Master file you wish to open. Opening a file will erase any information that is
currently in Calendar Master. You should save any event information you wish to keep
before opening a new Calendar Master file.

You can also specify a file to open when you start the program. If you specify the name of
a Calendar Master file following the name of the program CALMAST.EXE when you start the
program, the named Calendar Master file will be loaded. The easiest way to do this is to
setup a program item for Calendar Master in the Windows Program Manager. See your
Windows documentation for more detailed information.

Calendar Master files are plain ASCII files which you can look at and edit in your favorite
text editor.

The format of Calendar Master files has changed from version 1.0 to version 1.1. The
program will not read version 1.0 files. Registered users can obtain a utility to convert
version 1.0 files to version 1.1 format.



Deleting Event Information

You can delete event information in two ways. The first way is to navigate to the
appropriate month, open the Event Editor for the appropriate day, select the event and
click Delete. If the event is a Recurring event, the Delete Recurring Event dialog is
displayed which allows you to select a subset of the Recurring events to delete.

This method is fine for deleting small numbers of events but can be cumbersome for
deleting large numbers of events.

The way to delete large numbers of events is to select Delete Events... from the Edit
menu. This is useful for purging the Calendar Master file of old events (which will help
performance). Selecting Delete Events... from the Edit menu will bring up the Delete
Events dialog. Here, you can choose to delete all events before a certain date, all events
after a certain date, or all events. Note that this does not affect Anniversary events.
Select the desired delete method, the date if applicable, and then choose OK.

Of course, you must save the Calendar Master file for the changes to be permanent.



Exiting the Program

s

To exit the program, click on the Exit door on the Toolbar at the top of the Calendar
Display. You can also select Exit from the File menu. If you have not saved any changes
you have made to the information currently in Calendar Master, you will be asked whether
you want to save the information. If you choose Yes, the information will be saved in the
currently open file or, if a file is not open, you will be prompted for a directory and filename.




Registration of the Program

Calendar Master is a shareware program. This means that you can use it for a period of
sixty days in order to evaluate it's usefulness to you. After sixty days, you must either
register the program or delete it from your system.

Registration is accomplished by filling out the Registration Form and sending it along with
$10.00 US., to the address shown below.

Tom Hudgins
14722 Fawnglen Circle
Chino Hills CA, 91709

Upon registration, you will be granted a license to use the program and will be put on the
mailing list for notification of upgrades and enhancements.

You can also contact me through CompuServe at 73523,3314
(Internet: 73523.3314@compuserve.com)



Registration Form

Print this form by clicking Print from the File menu.

Please register my copy of Calendar Master.

Name:

Enclosed is $10.00 U.S.

Address:

City:

State:

ZIP:

Country:

Phone (optional):

| got Calendar Master from:

Comments:

Mail to:

Tom Hudgins

14722 Fawnglen Circle
Chino Hills, CA 91709-3403
USA



Font Effects

Font Effects in Calendar Master means the bold, italic, underline, and strikethrough affects
added to the font.



Event Types

Normal Events are events which have both event text and a time.

General Events are events which don't have a time associated with them. For example,
"Payday", "Pay Bills", or "School Pictures".

Anniversary Events are events that happen every year on the same date. This would
include birthdays, anniversaries, and some holidays. Anniversary Events do not have a
time associated with them.

Recurring Events are events which happen at a certain pattern like "every 3 days for 2
weeks" or "every month for 2 years". Both Normal and General Events can be recurring.



A PIM is a Personal Information Manager. This is a class of program which is used to keep
track of information such as Names and Addresses, Phone Numbers, Appointments, and
other miscellaneous information.



The Toolbar

The

Toolbar is the row of buttons at the top of the Calendar Display. These buttons are

used as shortcuts for frequently used operations.
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This button is used to open an existing Calendar Master file. The corresponding menu

command is Open in the File menu. All event information in Calendar Master will be
cleared before opening the new file but you will be prompted to save any changes you have
made before this happens.

g

open

=y
=

1

Exit

&)

]

This button is used to save the current Calendar Master information in the current file.

The corresponding menu command is Save in the File menu. If there is no file currently

, you will be prompted for the name of the file to save into.

This button is used to print the currently displayed Calendar Month. The

corresponding menu command is Print in the File menu.

This button is used to exit Calendar Master. You will be prompted to save any changes

you have made to the file before the program exits. The corresponding menu command is

in the File menu.

This button is use to display Calendar Master Help. The corresponding menu

command is Contents... in the Help menu. Remember, Help is available at all times by
pressing F1.



Delete Events Dialog

The Delete Events Dialog is displayed by choosing Delete Events... from the Edit menu.
This dialog is used to delete ranges of Normal/General event information. This does not
delete Anniversary events. Anniversary events can only be deleted using the Event Editor.
The Event Editor allows you to delete either one event at a time or subsets of Recurring
events.

The Delete Events Dialog allows you to delete all events, all events before a given date, or
all events after a given date. If you choose to delete events before or after a date, the
delete is not inclusive of the events on the given date (before or after, not on).

Note; you can also read the Calendar Master file into an ASCII editor (like Notepad) and use
it to delete events from the file.



Recurring Event Dialog

The Recurring Event Dialog is displayed when you click on the Recurring... option button
in the Event Editor. This dialog allows you to set the parameters of a Recurring event.

There are two basic parameters of a Recurring event. The first one is the frequency;
"Every 3 Days", "Every 2 Months", or "Every 1 Year". This parameter is set on the left side
of the dialog. Select the Every box and enter the frequency then click on the drop down
button on the units list box immediately to the right and select the units.

The other parameter of a Recurring event is the duration; "Every 3 Days for 2 Weeks", or
"Every 2 Months until 10/13/95". This parameter is set on the right side of the dialog. As
hinted in the example, the duration can be either some number of units or an end date. To
set an end date, click the Until option button and then enter the end date in the Date box.
The end date means "up to and including this date". Note that an occurrence of the
Recurring event might not land on the end date. Thus, if you specify "Every 2 Weeks until
10/13/95" and 10/13/95 is tomorrow, you will only get one event.

To make the duration some number of units, click the For option button, enter the number
of units in the For box and then select the units from the drop down list to the right.

When you have specified the parameters, click the OK button. If you change your mind
and don't want to make a Recurring event, click Cancel. The Recurring event doesn't
actually get entered into the event list until you select Add or Update in the Event
Editor.



Event Editor

The Event Editor is a dialog box that is used to enter and modify event information. At
the top of the display is the Day selector. This shows the day being edited and allows you
to change to the next day (right arrow) or the previous day(left arrow). You can also drag
the slider right or left to advance or go back up to 31 days. |If you click in the area of the
scroll bar between the slider, the day will advance or go back by one week. Also at the top
is the Close button which closes the Event Editor.

Next is the Event List. This is a scrollable list which shows the events for the current day.
You can select (click on) events in the Event List to modify or delete them.

At the bottom is the Event Edit area. This is where you enter or modify event information.
Enter the time of the event in the Time box and the text of the event in the Event box.
You select the type of the event by clicking on the appropriate option button. You can
override the default font effects by checking the desired boxes in the Font Effects area.
The buttons at the bottom allow you to Add a new event, Update a modified event,
Delete an event, or Cancel adding a new event or modifications to an existing event.



Calendar Display

The Calendar Display is the main display window for Calendar Master. This window
shows the calendar of the currently selected month (and the number of events on each
day), allows you to change the selected month, and allows you to load and save Calendar
Master files, and exit the program.

To view a specific month in the Calendar Display, you use the navigation buttons on the left
side of the window. The month being displayed is shown between the scroll buttons. The
inner scroll buttons change the month (the left button changes to the previous month and
the right button changes to the next month). The outer scroll buttons change the year.
You can drag the slider left or right to display previous or future months. If you click in the
area between the slider and the buttons, you will jump ahead or back by 3 months. The
additional buttons below the scroll buttons allow you to quickly display the current month
(based on the system clock) or hop directly to a specific month in the currently displayed
year.

Event totals for each day will be displayed on the calendar.
To open the Event Editor, click on the desired day on the calendar.

The Toolbar or the menu bar can be used to print, load and save files, and exit the
program.



Delete Recurring Event Dialog

This dialog box allows you to specify the subset of events of the selected Recurring event
to delete. You can choose to delete

Just the current event - no other events in the recurring series are changed.
All the events - all the events that match the selected event

All previous events - all the events that match the selected event that occur
before the selected day.

All future events - all the events that match the selected event that occur after
the selected day.

Select the option desired and then click OK to carry out the delete. Cancel aborts the
delete.






